Cycle Forums: Motorcycle and Sportbikes Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
119 Posts
Discussion Starter #1
I had my front brake pads changed and at first my bike would squeak until I got going over 30 mph or so.. it would NOT squeak when the brake was applied though.
I don't think it's the chain because I just lubed it 300 or so miles ago.
Now its the opposite, its squeaking when I apply the front brake (not the normal rubbing sound of the brakes..i know what thats like..its definitely a squeak)

and also, this might seem kinda weird- but ever since I had the front brake replaced, its harder to move my bike.. Im talking about just moving it from a stop while the engine is off. Why is that? that makes no sense to me.

-matt *6
 

·
Registered
Joined
·
1,360 Posts
Its just the pads bedding in, it'll do it for a while. Try not to be too hard on the new pads when they're cold, until they are bedded in well.
 

·
Registered
Joined
·
471 Posts
Maybe I'm nuts, but the fact that its harder to move the bike when its off, that would seem to me to say that the pads are actually draggin on the wheel...might want to have it checked out....
 

·
Registered
Joined
·
301 Posts
Yep, sometimes the pods wil get gunk in em, and wanna stick..clean em out, and the brakes should be fine..if not..then check for a possible warped rotor...
 

·
Registered
Joined
·
36 Posts
I'd check the job and make sure your pads are seated right

You shouldn't be getting drag when your pushing your bike...

Good luck...
Better to be safe than sorry
 

·
Registered
Joined
·
4,580 Posts
sounds like your pads are actually rubbing.

Some pads (same part#)wrk on different bikes with the same caliper but the rotors are thicker.So the pads "drag"The pads are probably too thick.(thivcker than oem)

just saw that you have a zx6r(they have tockico calipers)wich are used on NUMEROUS suzuki's(tlr,gsxr 750,gsxr1000,gsxr1100)sp it's a matter of them being to thick probably.
 

·
Moderator,
Joined
·
3,129 Posts
Do you have stock lines on or aftermarket? I noticed that my front 'drags' a little more since I installed my Kevlar lines. I would imagine that comes from the new lines not having the same 'flex' as the stock rubber ones.

Also if they are new pads give them time to wear a bit and allow for more room.. Cleaning out the pods won't hurt either..
 
1 - 7 of 7 Posts
Top